Bug when using HD-textures for "AD" on the QSS engine. Solution found!

Greetings! I ask for your help.

When using high-resolution textures on the QSS engine in some modifications or third-party maps, errors of blue or lilac textures periodically occur and textures from models of rocket boxes, cells boxes, keys and flying nails are shifted. The textures move diagonally from the lower left corner to the upper right corner. Color deviations of textures mainly occur on the modification of “Arcane Dimensions”. The textures of the ammo boxes are shifted not only on those maps where there is a modified “progs.dat” file, but also where it is missing. There are no errors in the console. The graphics settings are the same, both for the main game and for modifications. When using basic textures and skins embedded in the model, no shifting occurs.

Here are screenshots of typical errors:
https://drive.google.com/file/d/1s69Bsiy0sPHVPvrqgPjqozzx2GCMmbL_/view?usp=share_link
https://drive.google.com/file/d/1Yz8wWJmQ4idzMWcqi8_Pk3L77cgXVsJh/view?usp=share_link

sounds more like a filename conflict between replacements for the mod’s own models, and whatever replacements you have elsewhere (like the id1 dir). many mods provide new models by just replacing the .bsp file with an .mdl - but using the same filename(read: extension too).

(just going by your description as google drive links don’t work for me - infinite redirects)

By the way!

If you enter the “restart” command in the console after loading the starting level of the “Arcane Dimensions” modification, then all textures acquire the correct colors. But it happens that the texture colors turn lilac and blue again when the save is loaded.

There are no duplicates of textures. I specifically renamed the textures folder in the ID1 folder. Some HD textures disappeared after renaming the folder. :slight_smile:

Miracles!

I found a manual way to fix the problem with the wrong color of the HD-textures of the level and some ammo boxes every time the game starts. After downloading, you can do several ways:

  1. Type the “restart” command and restart the level - HD-textures will become the correct color, but the offset on some models of ammo boxes will remain.
  2. Disable texture replacement in the extra options menu and restart the level, then enable texture replacement and restart the level. Also, instead, you can enter the command “gl_load24bit 0”, then “restart” - HD-textures turn off, then enter the command “gl_load24bit 1” and enter “restart” again - HD-textures will turn on, but with the correct color and without offset on some models of aamo boxes.

But it needs to be done every time at a problematic level. Damn it!

P.S.: After loading the save file, the colors on the textures become incorrect again.

In case it is reel texture cross-overlapping - it is not a bug.
All You need is (love):
-find wrong painted texture name by any way
-find hd replacement inside Your HD_textures.pk3
-extract it to special -your_map_name- folder:
/textures/map_name/texture.tga inside id1 or mod folder

If still something wrong, add entire black picture named texture_luma.tga beside texture.tga

That’s should work.

[quote=qazzaq]In case it is reel texture cross-overlapping - it is not a bug…
[/quote]

Thank you, dear friend, I will definitely try to create “luma” files for problematic textures.
I have all the “maps/music/sounds/textures” files, etc., located inside folders and not in the “*.pak” archives. So it is more convenient to work with them and view or listen to them.

Since no one suggested anything, I solved the issue in my own way. But this does not mean that it was correct, but I got the desired result. Qazzaq alone prompted me to try to create “_luma” files, but creating them didn’t help to get rid of the wrong colors.

So. The problem with changing the color of HD-textures occurs only in the modification of “Arcane Dimensions” with external textures in “*.tga” format only on the “QSS” engine. On the “Dark Places” engine all colors are displayed correctly.

What I did. I have collected a bunch of available HD-textures and from several mods: AD Epsilon, Rivares and More Dimensions Epsilon. It turned out more than 10,000 textures. Selected textures similar to the original ones. I converted all the remaining 6000 textures to “*.jpg” format and everything worked. Everything, damn, worked! But I spent several days and nights performing tedious and identical actions for copying, pasting, sorting, renaming and deleting these files! It’s good that I found the program “AVS Image Converter” (or “XnConvert”), which allowed me to convert textures to another format at once. And as a result, the size of the textures after conversion decreased several times.

Apparently, something is written differently in the source code of the “Arcane Dimensions” modification or text settings than in the original game. But this is my problem, since I myself wanted to use HD-textures.

Maybe all of the above will be useful to someone.

WARNING!

Textures that are used for environment objects and have the first character “{” in the name (for example, grass, thickets, web, grids, banners, breaking windows, etc.) cannot be converted from “.png" to ".jpg” format in any case, only to “.tga" format! The ".png” format has a back independent layer of checkers, which denote transparency, and the “.jpg" format converts all layers into one with a white background and when you start the game you will see just a drawing on a white rectangular background. Such files need to be converted only to the ".tga” format and only with the help of a program that knows how to save this back layer. For example, the program “XnConvert” can do this (or “AVS Image Converter”, “ACDSee” and many others cannot do this).

If you have all HD-textures initially in the “*.png” format, then they will start on the “QSS” engine only after entering the “restart” command.