Lightning not working right in Quakespasm

Hello! I’ve started playing Quakespasm and noticed that light produced buy gunshots and explosions only visible on character’s models, but not on the level itself. I used to light some dark corners with shotgun and now it’s not possible. I tried to find a variable in console myself, but no luck. How to fix this?

There are some bugs you can easily overcome by doing one of the following things:

Brightness issues should be fixed with GLSL gamma in 0.90.1, if your
system supports OpenGL 2. For reference on older systems:

Some versions of Xorg and SDL have brightness issues.
Try setting “export SDL_VIDEO_X11_NODIRECTCOLOR=1”, or if you have
Xorg >= 7.5 and broken brightness, these patched libSDL binaries may
help.

o Gamma patched libSDL (i686-linux)
http://sf.net/projects/quakespasm/files/Support%20Files/libSDL_gamma_patched.tgz/download

o Gamma patched libSDL (x86_64-linux)
http://sf.net/projects/quakespasm/files/Support%20Files/libSDL_gamma_patched-AMD64.tgz/download

The “game” command doesn’t execute quake.rc in the new game directory
being switched to. This means any custom key bindings in a mod’s
config.cfg or special settings in a quake.rc won’t be loaded. The only
workaround is launching the engine with the -game command-line switch
instead of using the game console command. Or, after running the game
command, you can run “exec quake.rc” by yourself (YMMV).

It sounds like “r_dynamic 0” is set, try “r_dynamic 1” in the console.

Madfox, the problem is not about dark corners, it’s about dynamic lights working incorrectly.

ericw, r_dynamic is 1. Shots and explosions produce orange transparent blobs, but no light is seen on the level. Things like gibs and shells are being lit correcly even with “r_dynamic 0”. ProQuake has the same thing, Darkplaces works fine. And switching r_dynamic to 0 in DP makes it look exactly like the rest of the engines I tried, so it is about dynamic lights. They don’t work for some reason in other engines.

r_flashblend 0 - defaults to off in newer version of QS.

gl_flashblend, I think?

Yes, my bad.

YES! Yes, it is gl_flashblend! It was set to 1 by default, gl_flashblend 0 makes everything right! Thank you so much for help!