Memory pool sprung a leak?

Good morning!

I just tried launching map_tears for AD 1.8 through Quake Injector but I’m using Darkplaces.exe and Rygel’s Ultra High Rez textures.
The game launched, sat there for a good 30 seconds “loading” and then crashed.

I’m not sure if I should post the entire crash dump(because it is HUGE), but I saw these lines:

memory pool list:
size name
3561518k ( 3561784k actual) maps/ad_tears.bsp (-647973786 byte change)

LLVM ERROR: out of memory

I have 32GB of system memory

Is it possible for me to allocate more memory to the engine of my choice?
Also, should I switch from DarkPlaces to QuakeSpasm? Maybe especially since I’m using the High-Rez textures?

Thank you.

Covered in gibs,
Xeryn

Well, I tinkered with Quake Injector and my engine choice a bit.

Here are my results:
-Quake Injector with command line argument -heapsize 10000000, using DarkPlaces and Rygel’s Ultra HD textures in id1 folder,
to load ad_tears = Loads for a bit and then crashes, no engine output

-Quake Injector with command line argument -heapsize 10000000, using DarkPlaces and Rygel’s Ultra HD textures in id1 folder,
to load ad_start = Loads fine but normal textures and my HUD is a just a white/grey checkerboard.
I then walk through the portal for “Tears of the False God”. It abruptly stops loading and gives me the Darkplaces console which mentions “outdated engine build”. This is the most current version of DarkPlaces I can find.

-Quake Injector with command line argument -heapsize 10000000, using QuakeSpasm and Rygel’s Ultra HD textures in id1 folder,
to load ad_tears = Loads Tears of the False God just fine, but normal textures

Is my understanding correct in that Quakespasm doesn’t support Rygel’s Ultra HD Textures and only Darkplaces does?
Also, I can load Penile Devastation with Darkplaces and Ultra HD textures and it’s all fancy looking.
But when I try the Darkplaces + UHD textures with Epochs of Enmity, it loads fine but I have normal textures again.

Is there an engine that will support high resolution textures no matter what map/mod I run?

I really prefer Quake original “moldy” look, it’s what I grew up on.

I was just curious to see certain maps with these HD textures.

I apologize for being a n00b about this. I’m willing to learn everything I can.

Thank you very much for taking time to read this.

firstly, ‘LLVM ERROR’ sounds like a glsl compilation error specific to your drivers and the glsl DP is passing to them.

secondly, DP really isn’t recommended for ad_tears. last I tried it glitched out without default settings, you have to set weird stuff to disable its dubious ‘accelerated’ rendering to get it to stop glitching.
and either way its framerate is half of any other engine (even with all the extra fancy stuff switched off). its not a good experience.

regarding replacement textures - they’re custom textures. Generic texture packs like Rygel’s won’t include replacements for any of those custom textures. This is why you’re finding they work on one map but not the next.
At best you’ll get some ugly mismatch of high-res textures besides low-res ones, and none of the detail will match between them leaving the entire thing disjointed. You may be able to find map-specific texture packs that solve this, if you’re lucky.

ultimately though, you claim to ‘prefer Quake original moldy look’, yet you’re instead using DP and high-res textures, so I’m not really sure what you’re even trying to achieve here.
gl_texturemode gl_nearest_mipmap_nearest
is a basic approximation of quake’s original texture sampling that’ll work in more engines as-is than engine-specific modes that better approximate software rendering. Use that instead of high-res stuff if you’re actually going for quake’s original look.