Nehahra on Linux?

How does one go about it? The download of course comes with several .exes for Windows users, but is there any engine that runs on Linux and runs Nehahra?

I remember trying on DarkPlaces several times in the past and just finally giving up, as I could never get things to work properly (I think it would crash after the first map, or something). Quakespasm is my current go-to engine for everything, but I’m guessing it does not support Nehahra (yet, or any more), as I can’t get it to even start. Maybe someone here knows the answer…?

(FWIW, I did look at the documentation, but it seems geared towards Windows users and I guess might not be up to date with the latest engine developments … unless I’ve missed something, which is possible).

https://www.quaddicted.com/engines/requiem
https://github.com/eukos16/NGUNIX (i think)

Thanks, Spirit. I downloaded reQuiem from the link above. The interface is … “different”. It feels very clunky to me at the moment; probably because it’s so different from any other Quake engine I’ve used. It feels like something I would have to learn first before I can use it. Plus I have no sound.

You mean the menus? Bind both “close” and “prev” menu to Escape then it becomes nicer. Sound needs OSS or OSS emulation, I never managed to get lag-free OSS emulation to work so my system is using OSS.

that’s correct, Quakespasm doesn’t support nehahra, unfortunately. From what I understand it’s a bit invasive/messy to add to an engine, although it would be nice to have in QS.

Besides requiem, what about trying the windows engines that come with nehahra using wine? On OS X, most windows quake engines I’ve tried work fine in wine, although admittedly there is some sound lag and poor mouse resolution, but these may be specific to the mac version of wine.

Thanks for your advice, Spirit and ericw.

I couldn’t get the Windows engines to work via Wine at all.

As for reQuiem, it looks like I’d need to make some significant changes to my operating system to get its sound to work properly, which I’m not too keen to do at the moment. Maybe I’ll come back to this engine later.

So I gave DarkPlaces another try, and it seems to be working this time: I’ve tried loading a few maps via the console and they all started fine. It feels very laggy, however – my framerate is not too bad, but it’s as if the mouse in particular is not very responsive. But it looks like DP might be one’s best bet for playing Nehahra on Linux in 2015, if one’s system doesn’t use OSS. Success! (-ish)

(Ironically so far I am not enjoying Nehahra at all, and it seems to many of the same elements that makes it difficult to get running properly that also make me dislike it. As much as I respect the project as an incredible technical achievement that shows great skill and talent, I would personally have much preferred a series of fairly standard Quake maps without the heavy-handed story, the AI modifications, etc. Oh well.)

Not ideal, but have you tried http://user.tninet.se/~xir870k/ Nehquake port on Wine?

I played through Nehahra on stream last week using DirectQ 1.8.8 and apart from some rather annoying clipping issues in three levels (that went away temporarily when restarting the engine) it seemed to work fine. Though it’s irrelevant to this topic, of course.

Try “nomonsters 1” for a supposedly less-dodgy AI (pun intended).

For Wine you might need to pass -nolan (or just -noipx).

Nehahra is unplayable without nomonsters 1…

Theoretically there is also qudos’ port https://www.quaddicted.com/files/engines/nehahra-lq-1.0.tgz but since the sources were no included, it is broken on any reasonably modern system…

Thanks for the additional tips; will look into it.

Old thread, I know, but Nehahra simply has something that other mods don’t have. You know, that sort of “out of category” thing. :smiley:
Anyway, the Linux native Nehahra support is still a bit of a problem it seems.

I played Nehahra about 1 year ago or so on QDOS. I was setting up QDOS for old Quake stuff and having Nehahra in pure DOS is cool. It has some problems, but is fully playable and the functional integrated demo movie section in menu is great too.

I quickly tried some of the Linux-native Quake engines that should support Nehahra, results follow. But it was really rather quick, there can be some problems that I didn’t encounter.

The mentioned ‘nehahra-lq’ definitely sounds great, but indeed is broken. And since the sources are not available, it also makes this one sort of illegal binary I would say, but, yeah.

MarkV runs Nehahra just fine, although the movie section in menu is not implemented. Problem is that MarkV has no sound on my system (Mageia 8) and hangs on quit, which itself seems to be related to the sound problem, as it quits normally with sound disabled. It’s a pity, as my favorite engine is QS and MarkV is quite similar of course.
I briefly look in the source package, but it’s surely not so simple to build on Linux as other engines. I will eventually try, not so much time now.

FTE-QW runs it, but demo movie section in menu is not functional, it has problems with some skyboxes and music doesn’t play, but that’s not really a problem, as it’s mostly not heard in the game anyway.

Darkplaces from latest sources seem to run the game flawlessly so far, demo movies can be played from menu too. There is no mod music, but again, not a biggie.
DP is still quite buggy for general mass map Quake usage, so I will keep it only for Nehahra when I have time for another run. :smiley:

Maybe BJ will get bored enough one day and port his engine for Linux, who knows…