Some issues with Quake injector and installing maps

Hi,

quick introduction as it’s my first post here; been a fan of anything aesthetically ‘dark’ for years; I like dark atmospheric music, dark literature and of course I couldn’t but love Quake1 :slight_smile: I’m not a massive gamer but have been obsessed with this game for years and it was a great companion during my latter student years. Recently re-discovered it after a tip on the Quake facebook site (thanx!) and bought the game and two mission packs from Gog.com. Finished them all at nightmare level and found most secrets and secret levels. I thought that was it, but much to my delight I discovered there is a whole Quake1 community here, including several passionate people who constantly create new maps, mods etc. How wonderful :wink:

Unfortunately my technical skills don’t match my enthusiasm and that’s where I need your help, as I got stuck trying to download new maps. I downloaded and installed successfully Quakespasm, and reading the recommendations at Quaddicted I tried to install Quake injector but that’s where I get stuck. According to the accompanying readme I need to Double click quakeinjector.jar, or use the supplied
quakeinjector.bat. Unfortunately I don’t find any such named files in the archive after extraction. Help!

Another issue is the downloading of maps. I read the instructions on this thread: https://www.quaddicted.com/forum/viewtopic.php?id=382 and tried to change the ‘target’ on my properties which is “C:\GOG Games\Quake\quakespasm.exe” by adding some of the maps code leaving a space, e.g. -heapsize 65536 -game jam6 or -heapsize 65536 -game retrojam4 +map start
Unfortunately whenever I am doing this I’m getting a ‘Problem with the shortcut, the name specified in target is not valid’ type of error. So close but so far, aarghhh! Any assistance would be greatly appreciated as I’m rather excited at continuing to explore the mysterious worlds of Quake.

Are you sure you downloaded the https://www.quaddicted.com/files/tools/quakeinjector-alpha2.zip? Because quakeinjector.jar is there (no quakeinjector.bat, however). Or maybe you need to enable the display of file extensions in your OS in order to see it. If the Java Runtime Environment is installed, it should give the .jar files a special icon to set them apart from other files.

As for the shortcut issue, it’s because of the quotation marks. Simply removing them altogether should do the trick.

By the way, with Quakespasm you can also load mods from the console, e.g. game jam6, so no need for multiple shortcuts. On some occasions, it’s recommended to do exec quake.rc afterwards so special settings the mod requires are applied automatically.

Thanks, I re-installed java, downloaded from your link, and everything works. It seems that the Quake injector files were defaulting to ‘winrar’ instead of Java. Installing Quake injector has made it very easy to install and play maps so all my issues are solved at once :wink: Can’t believe how many maps there are out there I wasn’t aware of! I feel like 19 years old again :wink:

hi. i’m having some minor difficulties as well. mainly because i’m on a chrome book. also, do you guys know where i can rip a copy of the full edition of Q1?

https://www.gog.com/game/quake_the_offering

@KozzyP You should know that not every mod’s start map is called “start”… Check each mod’s readme.txt for instructions.

@aquakelovingdoctor You don’t get to ask here where you can RIP Quake, you ask where you can BUY it. The Quake community is usually adamant on being legit. Come on, it’s not that expensive! And you’re a doctor, you’re supposed to have a comfortable paycheck…

Quake Injector is giving me the following annoying error message every time I’m trying to load maps recently:
“Database parsing failed! javax.xml.ws.http.HTTPException”
Any suggestions?

@KozzyP
Im having the same problem, database cannot load, no idea what could be wrong

[quote=bartekmil]@KozzyP
Im having the same problem, database cannot load, no idea what could be wrong[/quote]
Presumably it must be a general problem with how the maps are being parsed by Quake Injector then!

I get the same error…was fine yesterday!

I did not allow non-HTTPS connections in the new config, updating to alpha03 should work: https://github.com/hrehfeld/QuakeInjector/releases

Working fine now after update…Thanks!

Ahh but now it doesn’t show the installed mods/maps. I know Injector isn’t a finished product though…

Can’t download Arcane Dimensions now though, think you said a mirror was down?

“Couldn’t find file! SSL peer shut down incorrectly.”

Hm, that’s not good. Did you put it into the same location as previously? It should pick up the installed maps from the installedMaps.xml file.

The SSL error is weird, is your Java up to date?

It is up to date yes.

Also can’t grab the file from the quakeaddict.com site…I get a network error.

Hmm somthings fish…starting happenning since yesterday when people were having issues with injector.

The file I mean is the “ad_v1_50final.zip” from the Quakeaddict site!

Heh,

I’m getting the same error: “Couldn’t find file! SSL peer shut down incorrectly.”, when in the middle of a download of a rather big file, RetroJam6 in my case.

For small packages it works fine, afaics.

MFX

[quote=mfx]Heh,

I’m getting the same error: “Couldn’t find file! SSL peer shut down incorrectly.”, when in the middle of a download of a rather big file, RetroJam6 in my case.

For small packages it works fine, afaics.

MFX[/quote]

Hey…try again it seems to working for me now.

Just downloaded Arcane Dimensions with no problems, earlier I was getting that error.

:slight_smile:

All working for me again as well since downloading alpha03:)

Nope,

still getting that error message when d/l Jam6. At 20 percent or so…
Hmm…