The game is very sluggish when playing large maps

I’m playing small maps (< 5MB) normally, but huge maps (> 10MB) don’t run smoothly. The frame rate drops down to 5 fps in some areas especially when turning around. This mostly happen with new maps with fog, which use extension packs.

What might be the cause?

Engine: QuakeSpasm 0.85.9
Tool: Quake Injector
System: Windows 7 Ultimate x64 SP1
CPU: Intel i5 750
RAM: 12GB

(The map sizes I gave in megabytes is the file sizes what Quake Injector shows in its info panel.)

Some of the maps that run sluggish in my computer:

  • Conflagrant Rodent
  • Fort Driant
  • Day of the Lords
  • Catatonic Fits of Despair
  • Arcanum Bonus Maps

(EDIT: I don’t know why but the variable values are not displayed in the embedded Autoexec.cfg code in the forum preview. But you can see them if you click the “Quote” button under my this message.)

Autoexec.cfg:

[code]//////// Key Bindings ////////
// …

//////// Client Movement Commands ////////
_cl_name “My Name”
_cl_color “0”
cl_bob “0.02”
cl_bobcycle “0.6”
cl_bobup “0.5”
cl_forwardspeed “400”
cl_backspeed “400”
cl_upspeed “200”
cl_sidespeed “320”
cl_yawspeed “140”
cl_maxpitch “120”
cl_minpitch “-120”
cl_movespeedkey “2.0”
cl_pitchspeed “100”
cl_rollspeed “200”
cl_rollangle “2.0”
cl_anglespeedkey “2.0”
cl_nolerp “0”

//////// Standard Quake Variables ////////
crosshair “2”
showturtle “0”
showram “0”
host_maxfps “64”
showpause “1”
bgmvolume “0.1”
bgm_extmusic “1”
gamma “0.5”
sensitivity “6”
volume “0.1”
lookspring “0”
lookstrafe “0”
noexit “0”
skill “1”
deathmatch “0”
coop “0”
pausable “1”
registered “1”
external_ents “1”
max_edicts “2048”

//////// Technical Graphics Commands ////////
r_drawflat “0”
r_fullbright “0”
r_speeds “0”
r_clearcolor “2”
r_waterwarp “0”
r_drawentities “1”
r_dynamic “1”
r_novis “1”
r_wateralpha “0.1”
r_particles “1”
r_quadparticles “1”
r_shadows “1”

//////// Mouse-Specific Commands ////////
m_pitch “0.022”
m_yaw “0.022”
m_forward “1”
m_side “0.8”

//////// Environment Commands ////////
sv_aim “0.97”
sv_stopspeed “100”
sv_gravity “800”
sv_maxvelocity “2000”
sv_nostep “0”
sv_maxspeed “320”
sv_accelerate “10”
sv_altnoclip “1”

//////// Other Settings ////////
scr_conalpha “0.5”
scr_conscale “3.9”
scr_conspeed “500”
scr_conwidth “0”
scr_crosshairscale “1”
scr_menuscale “3.9”
scr_sbaralpha “0”
scr_sbarscale “2.45”
scr_scale “3.9”
sensitivity “6”
sv_altnoclip “1”
sys_throttle “0.02”
vid_bpp “32”
vid_fullscreen “0”
vid_height “1000”
vid_vsync “0”
vid_width “1776”
viewsize “100”
volume “0.1”
vid_restart
+speed
+mlook
[/code]

You will have to set r_novis to 0!