Zircon Alpha 10 "DarkPlaces Mark V" With Mouse Driven Menu

Zircon Alpha 10 “DarkPlaces Mark V” With Mouse Driven Menu

https://www.moddb.com/mods/zircon-engine

Pics

https://media.moddb.com/images/members/5/4671/4670468/profileshots/8sham.png
https://media.moddb.com/images/members/5/4671/4670468/profileshots/8zom.png
https://media.moddb.com/images/members/5/4671/4670468/profileshots/8precache.png
https://media.moddb.com/images/members/5/4671/4670468/profileshots/8intel.png
https://media.moddb.com/cache/images/mods/1/58/57036/thumb_620x2000/z8.png
https://media.moddb.com/cache/images/mods/1/58/57036/thumb_620x2000/z3.png
https://media.moddb.com/cache/images/mods/1/58/57036/thumb_620x2000/pacm1.png
https://media.moddb.com/cache/images/mods/1/58/57036/thumb_620x2000/pacm2.png
https://media.moddb.com/cache/images/mods/1/58/57036/thumb_620x2000/pack.png
https://media.moddb.com/cache/images/mods/1/58/57036/thumb_620x2000/blackjack.png

Now comes with Linux binary or compile from source using “make sdl-release”

Hi Baker, another batch of incoherent thoughts based on alpha 10 testing:

customize brightness, customize effects and customize lighting submenus in classic menu recognize cursor keys, however the selected line in these menus is not highlighted in red. It is hard to know what line you are on if you want to use keyboard. It is a small thing but slightly annoying because I’m used to using a keyboard instead of mouse.

ALT-TAB problem - after alt-tabing to desktop and back the screen is frozen. Not the game itself, the game is still running and I can hear shooting or footsteps of my quakeguy, but the screen does not move. I can enter menu or console and start new level or new game, but after loading I still see the same view from the moment I alt-tabed to desktop and back. The game is till running in the background.

MP3 support? This is again a small thing. I can always convert music files to ogg, but would be nice if zircon recognizes MP3 files natively.

Classic liquid texture surface warping from quake - this one is something I would vote for with both hands. What we have now in DP or zircon is this strange “feature” of emulating liquid surfaces by moving the water/lava/slime textures to the sides and up and down, but the texture itself is static. If looks awful. I know that DP and zircon respectively support shaders, but it is hardly a solution. It kills a performance, you will have artifacts around the edges of water brushes, but most importantly it is not universal solution. Shaders are texture-name sensitive so it is necessary to create a shader script for each liquid texture. And there are hundreds of level/mods with countless custom textures… On the other hand QSS or Ironwail emulate classic surface warping that works everywhere in any mod/level. It is somewhat basic feature compared to the capabilities of shaders I know, but it works. And it looks way better than what we have now in DP or zircon.

bug with transparent foliage/spiderweb textures - these textures should be shot-able through. Copper uses this feature a lot… I have already mentioned this bug before when I was talking about Dwell where rockets explode upon contact with these textures, grenades bounce-off back… What is really strange is that AD also features decorative entities like spiderwebs and lianas hanging from the ceiling and usually these transparent textures work as intended. However, others are bugged just like in Dwell. I’ve even encounter one occasion when I was in long hallway with two spiderwebs blocking the way. One of the webs acted like non-solid for bullets/rockets/grenades and the other one was solid. I’m not talking about solid/non-solid from the point of view of the player. I could walk through both spiderwebs w/out problems. just strange…

one old DP bug that prevails in zircon - some tree models in /not only/ DA x-mas jams turn fullbright when you look directly at them. The moment cursor “touches” the tree model it suddenly turns fullbright. Everything is normal when you move the cursor away. Also, sometimes engine does not recognize transparent parts of these models and displays transparent parts of textures /leaves, branches/ as pink areas.

all for now, thanks for your work on zircon.

Thank you for the information. That is exactly what I need.

Could you tell me exact map names for the foliage/spiderweb thing?

some tree models in /not only/ DA x-mas jams turn fullbright when you look directly at them.

could you tell me exact map names for this one too

nice catch on the menu, DarkPlaces has like like 28 menus. I thought I got them all tested properly.

ALT-TAB problem - after alt-tabing to desktop and back the screen is frozen. Not the game itself, the game is still running and I can hear shooting or footsteps of my quakeguy

I have makeshift hack preventing the engine from simply crashing when whatever is going on there happens. Pressing ALT-Enter will fix the screen if that happens. For some reason it is losing the OpenGL window, I haven’t yet been able to track down why but I plan on it.

MP3 support.

Will think about … I’ll have to poke around in Quakespasm and see how much effort libmad is (that’s the mp3 library).

I used to know, haha. I’m slightly rusty. I’ve worked with libmad before, I shouldn’t even have to look at Quakespasm. I did stuff with it before Quakespasm was an engine, but swapping code back and forth with the Quakespasm guys for years, I know the code there quite well.

waterwarp

Do you happen to know a good looking shader for the kind of water effect you like? The rendering inside DarkPlaces is unapologetically shader based. If you know a great water shader in, say, Quake 1.5 or I might be able to simply have it use that if a cvar is set.

The method for texture water warp in regular Quakespasm is from FitzQuake which renders a texture onscreen every frame, captures it after twisting it and then erases the screen like it never happened. I would prefer to not do that, a shader would be way better.

Hi Baker

bugged tree models

ideal level to test bugged trees is Xmas jam 2020 for AD. downloadhttps://www.quaddicted.com/reviews/xmasjam2020.html

Screenshots below are from starting area of level xj2020_shades. That level is a three-bug-combo example.
1 - bugged transparent parts of trees
2 - tree with the crosshair on it is fullbright
3 - disappearing decorative textures:

There is a living fence like brush with transparent texture of little x-mas lights on it. On the left side of the left image the lights are visible, on the rights side of the left image the texture with little lights is incomplete. Image on the right side, taken from closer distance to the living fence, the lights suddenly appear out of nowhere. Texture disappears again when you step back a little.

https://www.imagevenue.com/ME168PFWhttps://cdn-thumbs.imagevenue.com/7c/2f/60/ME168PFW_t.png https://www.imagevenue.com/ME168PFXhttps://cdn-thumbs.imagevenue.com/b1/09/0d/ME168PFX_t.png

Other example of bugged trees is another level from the same pack - xj2020_vbs. Trees have bugged transparent parts, but they do not turn fullbright when you move crosshair over them. So… only a half-bug :slight_smile:

last example of strange tree behavior is level https://www.quaddicted.com/reviews/sp_maxx.html Screenshot is from the central area in front of the cathedral
https://www.imagevenue.com/ME168PPKhttps://cdn-thumbs.imagevenue.com/cf/d1/04/ME168PPK_t.png

**solid cobweb **
I am still searching the level I mentioned in my last post. However… similar bug can be found in new episode https://www.slipseer.com/index.php?resources/the-spiritworld.208/. This time it is not a decorative transparent texture but bloody waterfall. You can start map elders6 and directly in the starting area there are two bloody waterfalls on the both sides. You can walk through, enemies can pass through, but grenades bounce of and rockets explode upon contact. Shells and nails cant shoot through as well.
https://www.imagevenue.com/ME168PRBhttps://cdn-thumbs.imagevenue.com/69/65/f8/ME168PRB_t.png

water warp
It’s been a while since I was fiddling with shader scripts. My conclusion is that shaders can look nice but the unavoidable artifacts around the brush edges ruin the overall impression. I tried to make something similar to water in old Unreal 99 - subtle swirling/bubbling effect, but DP shader capabilities are limited. I found out that classic quake water warping looks better and I would prefer universal solution similar to the Ironwail over shader-based any day of the week. I can dive back into shader scripts and try to come up with something nice but it will take some time.

I am not a coder so I don’t understand what is wrong about the way Ironwail renders water. Is it inefficient? Or just ugly codding?

Great details.

Yeah, fence texture support for model textures was something I did a engine tutorial on, pushed heavily and eventually I think ericw added to Quakespasm in I think early 2018. There is a model flag for the .mdl.

DarkPlaces development was already in a sort of inert state by then.

Looks like a lot of gremlins to sort through.

Keep your eye out for a good water shader in any DarkPlaces mod.

On mp3 support … doing this right is going to be more work than expected … here’s why …

We think of engines like Quakespasm as having “ogg” support. Aside from fteqw/darjplaces they really don’t.

They have ogg cd track support. DarkPlaces has true ogg support … for everything everywhere like you could make ogg monster sounds.

The way DarkPlaces handles it is going to make mp3 take a decent chunk of time to implement, so this will be a lower priority.

MP3 is just a nice to have feature. Converting MP3 tracks to ogg is simple so if it is complicated… do not waste time here. there are plenty of bugs to kill elsewhere.

Fixing transparent parts of the trees is simple as well - I exported bugged model textures, added transparent layer, manually deleted pink areas, saved textures as TGA and load them as external textures. It works, but it is a nuisance…

one last note - zircon is much slower in large maps, but there is an exception. I tested AD level https://www.quaddicted.com/reviews/biome-pritchard.html and that level “features” serious fps drops in some areas with DP engine. However, zircon handles this level much better. There are slowdowns but not nearly as brutal as with DP. interesting…

Looks like I may have the fence textures on models done.

The reason that DarkPlaces was highlighting the tree was that DarkPlaces uses the same flag for something else that I believe was only used in a single mod called Prydon Gate.

The flag indicates you can select the item in-game.

That being said, I don’t think anyone except engine modders are aware of the mod Prydon Gate.

I have added the “fence support” and removed the Prydon Gate model flag check on model load.

I will say, I always wondered what that feature was like where you if you look at something it highlights. now I know.

Great news Baker.
I have a list of several maps that have these disappearing textures in them. I am already looking for testing.

Prydon gate…I remember that… mod from the era right after dinosaurs died out. That flag certainly won’t be missed.

https://media.moddb.com/images/mods/1/58/57036/xj2020_shades.jpg

I might add … I can no longer cause black screen ever with minimize or ALT-TAB.

This doesn’t mean it can’t happen, just that I cannot cause it to happen. So some changes to improve the video may have fixed it.

It was a hard situation for me cause and seems impossible now. Is it fixed for everyone, not sure!

But the window behavior now is really nice.

Add: Prydon Gate will still work, I have it behave the Prydon way for Prydon. Prydon Gate is unharmed by the changes.

https://cdn-thumbs.imagevenue.com/69/65/f8/ME168PRB_t.png

In Zircon, I shoot the waterfalls, the rockets go thru.

In Quakespasm too.

I must be doing something wrong?

Cannot reproduce bug.

I’m going to release a new version within next hour to get new changes out.

that’s strange… I encounter these non-shootable waterfalls /that also block enemies line of sight/ in several mods - eg. smejjam or dwell

I found that level with two cobwebs. It’s xj19_ionous form xmasjam 2019. Right in the starting area there is a cave with two cobwebs. One acts normal, the other blocks projectiles. Link https://www.quaddicted.com/reviews/xmasjam2019.html

EDIT I.
I 've just tested new clean Q1 installation and both bloody waterfalls in Spiritworld and cobwebs in xj19_ionous from xmasjam2019 are not solid for projectiles anymore. I need to find out what file in my working Q1 directory causes conflicts. Sorry for false alarm.

EDIT II.
I was not using the last version of zircon - alpha 11 from moddb.com - that was the problem. I somehow mixed files… my mistake. From the quick testing the only problem that remains is not shootable waterfalls in smej2 level smej2m4. That bug is still present in this level, but smej2m4 is way beyond what zircon can handle. Level works, but fps is just abysmal. Looking forward to the next zircon release.

Will look at cobwebs right now …

The cobwebs at the start of xj19_ionous

I can walk through them and shoot thru them with rockets.

I will get update out …

Also fixed the menus where keyboard nav was not highlighting.

(Around 45 mins or less, I check all code and make sure changelog has everything then upload.)

Updated

https://www.moddb.com/mods/zircon-engine/downloads/zirconenginewindowsonly20230414

Downloading right now. I updated my previous post to clarify my mistake.

new version test

good
all menus fixed - check
transparent trees are ok, no pink branches - check
trees no longer flicker - check
lianans and other decorative props are ok - check
fps increase in big levels - check

I tried d2m8 from Dwell and even though still not stable 60FPS, definitely much much better than previous version of zircon. As of now we can say that zircon is fully compatible with Dwell. Great job Baker.
I also tried smej2m4 from Smej2 pack and FPS is better than before. Still bit laggy, but playable.

problems
Problem with solid waterfalls in smej2 - still there.
disappearing props in the distance - still there

the little lights on the living fence brush still disappear, the same with flags in smej2end map. Baker, can you please confirm it? Maybe the problem is again on my side.

https://www.imagevenue.com/ME168UW5https://cdn-thumbs.imagevenue.com/aa/ac/01/ME168UW5_t.png https://www.imagevenue.com/ME168UW6https://cdn-thumbs.imagevenue.com/1a/1f/10/ME168UW6_t.png

suggestion
default crosshair is almost invisible. I can adjust it in console, but can you add crosshair size/color sliders to the menu? Would be nice…

Whew! I’m glad most of those were “Check”.

I was getting worried!

Crosshair, I’ll make alpha 0.9 or something instead of 0.5 default.

And I’ll look at your extra map reports and see what is up.

I’ve asked Sock if he wants to help me polish a Quake 3 map format singleplayer kit for Quake 1 for Zircon. If he says “yes”, I’ll be switching tracks to that for a few days.

I’m glad this is getting more polished and offering a better experiience.

I’ll see if there is good place in menu for crosshair stuff.