Quake Injector alpha06, fixed server connection issues

Thanks to https://github.com/jjelliott the recent breakage of the Quake Injector has been fixed.

You can download the new version (alpha06) at https://www.quaddicted.com/tools/quake_injector

Have fun!

1 Like

Does the Windows EXE version need java installed? Perhaps a specific version?
The java version of QI starts (after I updated java) but the exe fails to start with an error message:

Java Virtual Machine Launcher
Error: Could not create the Java Virtual Machine.
Error: A fatal exception has occurred. Program will exit.

No, the entire point of the exe is that it should just work. It has a whole Java environment bundled in, that’s why it is so huge. Damn :frowning:

Maybe some permission issues? Can you try running it in a command line window to see if it prints more information?

Think I’ve figured it out. I had extracted the new exe version over the existing one I had from before (alpha 5). I did make sure I told it to replace files; tried one more time to be sure. Then QI fails to start with that error.

Tried again but extracted everything in an empty directory and now it works.

Copied the two DB xmls and the config files to the new version and it looks like everything is OK.

Awesome, thanks for sharing the fix. I’m sure others will run into the same issue.