arcanum in darkplaces!!! help..

. hi ,
recently, i decide to play arcanum, the engine i use is darkplaces.
in the review and the readme file of the pack i see it must the drake mod to run.
i download, unzip, and put the arcanum files in the drake subdirectory, i entered the game, the demo runs normaly, but when i put ‘map arcstart’ the game crashes. anyone help…
the screenshot on the review appears is execelent i want to play it…
. thks for anybody help…

What’s the error/crash message?

no exibed error messages, only exit the game when i enter using the command line -game drake +map arcstart
drake is the name of subdirectory of the mod.

. you can play this normally??

darkplaces doesn’t crash for me. I have a June 8 2014 build, I launched the engine and typed “gamedir drake” then “map arcstart”.

Couple ideas… check that you have the latest stable release:

Make sure your id1 directory is clean, with just pak0.pak, pak1.pak, and possibly music.

If that still doesn’t help maybe do a fresh download/install of drake + arcanum.

make a printscreen of any map of arcanum with darkplaces??

for me appears in the console ‘mod_loadmodel: model “maps/arcstart.bsp” is of unknown/unsuported type
couldn’t load map maps/arcstart.bsp’

I’ll look into this; just so you know, even if you don’t get this working now, I’m planning to release a (heavily tested, coop-supporting) compilation of all my maps some time this year.

what build of darkplaces you recommend for play arcanum?

My DarkPlaces build is actually quite out of date (2012), but I just ran arcanum (arcstart) with no crash. Can you load arcanum1.bsp?

Can you load arcstart in any other engines?

in the fteqw and glquake don’t run

you see the error message above…
it appears for me what is the causes and how fix it??

Try FitzQuake - get the latest version here:
It’s generally really stable.

You can’t load any Arcanum maps in any of those 3 engines?

Maybe there is something wrong with the version of Drake you have. The last released version of Drake comes with the map “Something Wicked This Way Comes” so you could try downloading that (

If you have a clean Quake directory, the latest Drake, Arcanum, the latest DarkPlaces, and have tried other engines, then I’m kind of stumped. Maybe a hardware or driver issue? What operating system are you using?

thee drake version i use is this .
in the something wicked is used the bsp2 map format darkplaces support it??

Hi, yes, DarkPlaces supports the BSP2 format of Something Wicked (this was added after the release of Something Wicked).

What operating system / hardware?

actually i playing on linux mali 400 gpu
the video board of my pc burned =(.

open gl 2.0

what the minimum requirements of machine to run arcanum without bugs??

Well, your error sounds like a Darkplaces engine issue, but it could also be the video drivers… for system requirements, I’d say anything 5 years old or less with a graphics card should be able to play it. Even if it’s older that should just cause lag, not a crash. Have you used the command -heapsize to give the game access to more memory?
Ie, Darkplaces -heapsize 9999 -game drake +map arcstart

Also make sure your Drake and Arcanum are in one and the same directory. As I said if all of this doesn’t work out, there’s a forthcoming update to all my maps.

DP allocates memory dynamically, there’s no need to set a heapsize. Besides, 9999 is about 10MB… I think even old software Quake used more!