Damned Fortress

Hey everybody,

I’m a game design student and for the start of our second year we were tasked with creating our very first quake level in 7 weeks. This is my submission for the block. The Damned Fortress!

You find yourself trapped in an underground jail cell, with the only way out being through your captors. Out of the mysterious castle that blocks our path.

Game Link: https://www.quaketastic.com/files/DamnedFortress.zip

Screenshot 1: https://www.quaketastic.com/files/DFCourtyard.png
Screenshot 2: https://www.quaketastic.com/files/DFEntranceHall.png
Screenshot 3: https://www.quaketastic.com/files/DFGatehouse.png

Not bad! I had fun with it but there were a few issues. One was the damaging water - I couldn’t find a way out. I think there should be a way back up in case someone falls in (or is just looking for secrets, like I was). Or, if its just meant to be a trap you fall in and die, just kill the player right away. Why waste time? haha

I couldn’t figure out which door had opened when I shot the switch by the silver key for the longest time. And the area that opens doesn’t let you know that you found a secret when you enter it, which would have clued me in. Not a big deal, but feedback letting the player know “this is the secret, this is what you opened” will cut down on some confusion and wasted time.

I did like the next secret, always a fan of secrets that give you a new weapon or gives you a weapon early. There was a lot of ammo on the map, but I prefer that than too little. I appreciate that you gave lots of the weapons so we could have fun with them all.

Something really strange happened at the end. When the final door opened I entered the area, and then I think I was being killed by invisible monsters? I’m not sure what was going on, but I was taking sporadic damage and couldn’t see where it was coming from. I tried it again and waited outside of the door, and saw monsters then coming out of that area (visible this time) so I was able to kill them and finish the level. I think you were going for something cool and ambitious there, but it seems to not work if the player actually enters that area. Maybe some way to block the player from entering that area would have worked better? OR maybe it was all just a weird bug, no idea, haha.

Sorry if this all sounds overly harsh. Its impressive to make all this in seven weeks, I’m sure longer time would have ironed some of this out. And you still made something fun.