Help installing QuakeSpasm on Mac?

I’ve downloaded QuakeSpasm onto my computer but when I try and install it I get ‘W_LoadWadFile: couldn’t load gfx.wad’ come up.

Can anyone help me out?

Would aprpeciate any help as am very looking forward to applying Arcane Dimensions 1.5.

Mny thks.

Sure, here is what the file/folder structure should look like:

One thing to note: when you extract the file, you need to drag and drop the contents ( and the other files) to another location, in this case I dragged them to a “quake” folder on my desktop. Trying to install the id1 folder in the QuakeSpasm-0.92.1-osx-SDL2 folder created when you extracted the zip won’t work, due to a security feature of macOS.

Edit: Specifically, you need to move QuakeSpasm out of your Downloads folder for it to work. The macOS feature causing the problem is “Gatekeeper Path Randomization”, see e.g.
I’m not sure if that was causing the error you got but it’s one possibility.

yeah its still not working - i think im missing something really basic.

Will let you know if i have any success.

I’m actually having the same problem. I’m on macOS as well. I’ve been using QuakeSpasm for years just fine. I just had to reinstall macOS and erased my hard drive and I’m doing a fresh install. I wanted to try out Arcane Dimensions 1.5, which I haven’t even put in the Quake folder yet.

I’m getting the error:

Quake Error
W_LoadWadFile: couldn’t load gfx.wad

I recognize this error and it normally means the Quake pak files are not found.

I’m unsure if I’m using the wrong structure because I use a couple different Quake programs, but my structure does match the image from above.

I’ve got the folder and along side it at the same level I’ve got my id1, rogue and hipnotic folders.

Maybe something else is wrong. I’ve got QuakeSpasm in the Documents folder.

The non-SDL2 version works. Download that version. I don’t know why the SDL2 version isn’t working.

Where is not the non-SDL2 please?

Can you let me know any other things i need to do to install and play? Mny thks

It really shouldn’t make a difference though.

Yes, normally the “W_LoadWadFile: couldn’t load gfx.wad” means the id1/pak0.pak was not found.

If you have the “id1” folder installed correctly (just have it in the same folder as the, and still get the “couldn’t load gfx.wad” error, the only explanation is the Gatekeeper Path Randomization thing I mentioned.

To disable Gatekeeper you have to Drag&Drop the QuakeSpasm .app itself, moving the folder won’t work.

Where is the Pak files please?

Apologies i have looked online and know it comes with the main Quake, but can’t find it and can’t install it form steam as even though I have Quake it won’t let me install it on the mac.

I have the pako.pak now, in the quakespasm app but it’s still not working - do i need anything else? the id1?

its definately the id1 file i need.

id1 isn’t a file, it’s the directory you put pak0.pak and pak1.pak in.

The only files you need from Quake are pak0.pak and pak1.pak. Yeah, it’s a pain that Steam doesn’t give you access to those on the mac version. Could install the windows version of steam using Wine.

i´m having the same problem. the non-sdl-version works perfectly, the sdl-2-version is complaining. i hope that there is at some day a new non-sdl-2-version coming out so i can play ad_sepulchur.

@nono try the v0.93.0 RC1 build, it has better error messages that should help narrow down what is wrong:

Had the same problem. Solution?

Do not click the QuakeSpasm icon in Finder. Instead, right click and select Show Package Contents, navigate to Contents/MacOS and start the unix executable “QuakeSpasm”.

Alternatively, run the same file from the Terminal.

Reason: if you click the, the system will clear its current working directory so it won’t find the data files.

Quiark’s solution works for me. An alternative:

In the settings that pops up include -basedir /Volumes/data/games/QuakeSpasm in the “Command line parameters” field. Where /Volumes/data/games/QuakeSpasm is the directory resides in

I just wanted to say thank you to Quiark and dhau for their comments. I’ve ran in to the same problem on my Mac (with both versions of QuakeSpasm) and have been scratching my head wondering why it wasn’t working. Both suggestions worked so cheers!

I had QuakeSpasm in a folder called ‘quake’, in the ‘Games’ folder of my ‘Applications’ folder and popping this in to the Command line parameters box fixed it for me:

-basedir /Applications/Games.localized/quake

If you can’t figure out the directory path to put, go to the enclosing folder for QuakeSpasm and right click on it to bring up the contextual menu. Select “copy” with the alt key held down so it changes to “copy x as Pathname”. This can be pasted after "-basdir " in the Command Line Parameters box when QuakeSpasm starts (ensure there’s a space after “-basdir”).

-basedir /Applications/Games.localized/quake

This one is really works- use it.

I also want to say THANK YOU to Quiark and dhau. I was quite literally pulling my hair out trying to get Quake to run on my m1 powered Mac mini. And now, thanks to them, I can easily run it. Yay!

Note that I tried both ways and settled on simply double-clicking QuakeSpasm-SDL2 (version 0.95.1) and entering “-basedir /Users/randy/Desktop/QuakeSpasm-0.95.1-osx-SDL2” for the command line parameters and selecting 2560 x 1440 32 Bit for the resolution and color depth.

And seriously, it looks marvelous!