Help needed: Mails to gmail are getting blocked

Gmail seems to be blocking mails from now because there is no SPF record defined and a third-party sender is used:

$ dig mx		3600	IN	MX	10

I have no idea about this and documentation online is overwhelming. Anyone know what exactly I have to set up at the DNS TXT record? Simply v=spf1 ~all?

“include:” causes the given domain name’s spf records to be included, but that domain doesn’t have any spf record so you don’t want to include it like that.

If it’s the case that the email is always sent from an IP that matches what your MX record points to, then this would be good for you:

v=spf1 mx ~all

I peeked at the last email I got from quaddicted and saw it was from the IP address that your MX record points to, so that should be good. After you set up the record, in Gmail you can press “show original” on a new email from the site to see if it passed the SPF check.

(If that’s not the only IP address you have sending emails, then you can either add those IPs with ip4:/ip6: terms, or just throw in the towel and make an explicit accept-everything SPF record by using “all” instead of “~all”.)

Awesome, thanks! I think all the outgoing mail is using that mail server so let’s see what happens :smiley:

Actually, I will need to set it up for other sites hosted as well (,, etc). How could I specify as the outgoing mail server?

Assuming you want to be able to send email with the from address as,, then

  1. if you want to also be able to receive emails sent to those addresses, then set each of those domains to have an MX record of “”, and then set the TXT SPF record to the same thing as quaddicted: “v=spf1 mx ~all”.

  2. if you don’t care about being able to receive emails sent to those addresses, then you can just set each of those domains to have an SPF record of “v=spf1 ~all”, which makes it allow whatever does (so’s MX record). I’ve tested that this would work as expected with

Thanks again!

Somehow I think I didn’t set up the record correctly earlier. Now it is v=spf1 ~all which should mean that both a server under each domain may send mails and receivers are asked to softfail other senders.

Oh and it would be super helpful if people would try password reset mails or volunteer to receive a mail via the messaging system of the forum.

Same for and which I also updated.

shoot me some emails… I can test

Oops, that was absolutely wrong, “include:” means “use that domain’s settings”. What I wanted was “a:”. I thought I had figured it out too early ;o)

I hope the records are ok now. I will try to send you a mail (again, the other one a couple of days ago probably didnt come through), dumptruck_ds

I got confirmation that it works now.