Help with Quake Injector - Maps not loading

I just discovered Quake Injector and downloaded the newest version. I have Java and I tried starting all the .jar files. I can see the main interface but no maps are appearing in the list. I tried clicking the refresh option and nothing. I’m using the newest version of Java. Do you still have to use Java 6 even in the Alpha 3 version?

Please help! I’d love to get this working.

It should work fine with the latest Java (which you should always update to). Are you sure there is no firewall blocking it from accessing the internet?

Thank you, but I did check that the firewall was not blocking it…it’s very strange. It just doesn’t download the map list at all :frowning:

I’m having this problem as well. I’m using the OpenJDK build from Azul. I added my Quake directory, engine of choice, and download directory, but I still don’t see anything.

Another issue I’m having is that when I check the boxes to indicated that hipnotic and rogue are installed, the setting doesn’t persist. When I open settings again, the boxes are unchecked.

My firewall isn’t blocking anything as far as I’m aware. I’m not seeing any outgoing network activity from Quake Injector whatsoever when I check the network activity monitor.

FWIW the hipnotic/rogue thing is known:

Dunno about the larger issue though.

I installed an older version of Java and it worked for me. Downgraded from 10 to 8. Settings are saving, maps are downloading and playing.

Thanks for hints. Its working for me too now.

I’m having the same issue with the latest OpenJDK. Does this mean the Injector only works with Oracle Java? The download page for Quake Injector claims it works fine with OpenJDK, though.