Help with Quakespasm-Spiked

Hello, I have been trying to get Quakespasm-Spiked to work on my computer as I am currently using regular Quakespasm, but I keep getting this strange error message whenever I try and launch the engine, and I cannot find anything about it online.

“Image_LoadTGA: gfx/backtile.tga is not a type 2 or type 10
targa (3)”

I do not even know what the file is that the error message is referencing, as I cannot seem to find it anywhere in my Quake folder tree.

Does anybody know what is causing this?

Error caused by custom staff are You used.
First of all, look for this [backtile.tga] file in Your Quake folder
and remove it if exist.
If not, look for gfx.wad in \id1\ folder and, of course, remove it if exist.
If still not, look for gfx.wad in every .pak file in id1\ folder and mod folder You try to launch and remove it if exist.

The only one gfx.wad shuold be inside pak0.pak. If it so, Your gfx.wad is corrupted and must be replaced.

gfx.wad has nothing to do with tga formats.

you should instead look for any id1/*.pk3 package files, and move them away (or delete them). chances are if there’s one bad image in there then there’ll be more so its probably a waste of time going through the entire package.

(tga type 3 is actually just a greyscale image, but qs(s) doesn’t have code for that variant of tga and just lazily aborts instead)

Thank you Spoike for answer! Glad to see how quick QSS support is!
I tried to reproduce this error by placing custom BACKTILE.tga into gfx\ folder.
It only happen with corrupted BACKTILE.tga file. Engine ignores 32-bit tga with alpa and non power-of-two image (of which there are many in custom .pk3 files).
The only way to avoid troubles it not use custom (HD) stuff.

Thank you, everybody, I found the problem. I had a copy of Rygel’s old texture pack in my ID1 folder leftover from when I used to use Darkplaces as my primary Quake 1 engine. Rygel’s texture packs are .pak3 files and not compatible with Quakespasm or Quakespasm-Spiked.

By the way, has anybody heard anything on when the Quake 1.5 mod is going to be made compatible with the Quakespasm engines? The author said he was going to get around to it, but it has been awhile, so I wonder if it was abandoned.

Unfortunately, the current version of the mod “Q1.5” is compatible only with “DP”, because it uses the effects of this engine + SMC mod: water, decals, slow motion, scripts, advanced q15-config, etc.

One other thing I have noticed with Quakespasm-Spiked, there is a “kick” melee attack that is bound to the left mouse button by default. How do I bind this attack to another key, as it disappears when I rebind the mouse buttons to different actions, and there is no reference to it in the “Controls” section of the Quake menu?

There is no quick hit in “QSS” - this is a modified file “Q1.5” that is compiled into “progs.dat” using the “SMC” mod and the “impulse 20” command. It can be written in “autoexec.cfg” like a rocketjump.

There is no quick hit in “QSS” - this is a modified file “Q1.5” that is compiled into “progs.dat” using the “SMC” mod and the “impulse 20” command. It can be written in “autoexec.cfg” like a rocketjump.[/quote]

I am not sure what you mean. Impulse 20 does not appear to do anything, so when I try binding it to a key, nothing happens.

“impulse 20” is the “Quake 1.5” command for “Dark Places” and it assigns the action “kiiskisk”. All this works only in “Dark Places” and the “SMC” mod with its additional settings and scripts. There is none of this in “QSS” engine.