Installing Trenchbroom

I would like to start making Quake maps with Trenchbroom. The Problem right now for me is trying to figure out how to open or even find the program once I’ve downloaded it.
I’ve downloaded it from the main Trenchbroom site but once I download it, it just has a bunch of files that I can’t do anything with yet and no actual program to open etc… I’m probably missing something simple here…
Any help would be great thanks

[quote=DH1988]I would like to start making Quake maps with Trenchbroom. The Problem right now for me is trying to figure out how to open or even find the program once I’ve downloaded it.
I’ve downloaded it from the main Trenchbroom site but once I download it, it just has a bunch of files that I can’t do anything with yet and no actual program to open etc… I’m probably missing something simple here…
Any help would be great thanks[/quote]

you cant launch Trenchbroom?
you use win of linux?

download here :
https://github.com/kduske/TrenchBroom/releases/tag/v2019.6
scroll down and choice your OS.

https://www.quaddicted.com/files/wads/ textures (default pack id_base.wad need google search)
https://github.com/ericwa/ericw-tools/releases/ compilers

for example my CompilationProfiles.cfg

{
“profiles”:
{
“name”: “unnamed”,
“tasks”:
{
“target”: “${WORK_DIR_PATH}/${MAP_BASE_NAME}-compile.map”,
“type”: “export”
},
{
“parameters”: “${MAP_BASE_NAME}-compile.map ${MAP_BASE_NAME}.bsp”,
“tool”: “/media/oem/hdd500/games/quakesoft/Worldcraft/quaketools/ericw-tools-v0.18.1-Linux/bin/qbsp”,
“type”: “tool”
},
{
“parameters”: “-soft -extra4 ${MAP_BASE_NAME}.bsp”,
“tool”: “/media/oem/hdd500/games/quakesoft/Worldcraft/quaketools/ericw-tools-v0.18.1-Linux/bin/light”,
“type”: “tool”
},
{
“parameters”: “${MAP_BASE_NAME}.bsp”,
“tool”: “/media/oem/hdd500/games/quakesoft/Worldcraft/quaketools/ericw-tools-v0.18.1-Linux/bin/vis”,
“type”: “tool”
},
{
“parameters”: “+map ${MAP_BASE_NAME}”,
“tool”: “/media/oem/hdd500/games/quake/ezquake-linux-x86_64”,
“type”: “tool”
}
],
“workdir”: “/media/oem/hdd500/games/quake/id1/maps”
}
],
“version”: 1
}

Ok thanks, I’ve launched it now. Don’t know what I did wrong before. Now onto attempting maps…

nice tech video https://www.youtube.com/watch?v=gONePWocbqA