Quake Injector Error "Unexpected end of ZLIB input stream"

Hi, new to the forums and for the most part new to the custom Quake world. I love the idea of the Quake Injector, which for the most part works great, yet I have been running into an issue with certain maps such as Nehahra for example. When I click install it runs for a few moments but then will suddenly error out with the error “Couldn’t open file! Unexpected end of ZLIB input stream”. My main engine choice is DirectQ but I also tried to use Darkplaces and Quakespasm just to see if it was some sort of issue with the engine but I have not been able to get it to work.

Does anyone have any ideas or input? I really love what I’ve played of the custom maps so far and really want to take advantage of the plethora of single player conent.


That error means that the downloaded zip file is damaged or incomplete. I think we don’t throw it away then so this might be a very annoying problem with no apparent solution in the tool. Try deleting the zip files from the Download Directory and re-install then. It should downloaded them again and hopefully not do another error.

Ahh, glad to know it’s not a problem with Injector since I love using it. Unfortunately your suggestion did not work, I just decided to boot up Nehahra the old way, thank you for your response though!

Hm, that’s not a satisfactory solution :frowning: I have no idea what is happening though. You were able to download https://www.quaddicted.com/filebase/nehahra.zip directly and it was intact?

Oh man I’m sorry, I didn’t think to check back after I got it working. Shameful manners on my point. I just tried to download the nehara link you sent me and I get an error when it finished downloading…

The archive is either in unknown format or damaged

I use Winrar if that makes a difference.

First of all, sorry because of my bad english
I had the same problem as user missilecat, all of my quakeinjector downloads (especially maps that have 50mb in size) ends with “Unexpected end of ZLIB input stream”
When i tried to download directly from quaddicted site, most of them stalls at 13 or 12mb downloads, leaving a corrupted, unextractable file. This is a list of files that I have tried to download (through quakeinjector or quaddicted direct downloads):

All of them failed. curiously small sized file such as m_palace.zip or alk05.zip (the savage sanguine by Kona) succesfully downloaded
Any help will be appreciated. Thank you very much!

It works perfectly fine for me so it would help if you guys could share more information.

For example (if you feel comfortable sharing this):
Where in the world are you?
What is your ISP?
How slow are the downloads going?

Hello, thanks for the response!
I’m downloading from Indonesia, with 1.0 mbps download speed. The average download speed (in case of Quoth) is 5-6 mins . But when i tried to download that file from this site somehow the download abruptly ended,
It produce same results with quake injector :frowning:

yeah ive been having the same problems, any .zip over 50 mb seems to fail around the 80% mark while installing. downloading from the site directly works fine. ive tried deleting the problematic files but the problem still occurs after retrying. i live in the usa btw download seemed to cap at around .2 MB per second

wait correction the problematic files still are corrupt when downloading via the site, specifically rrp.zip . it seemed fine at first, but i guess not, should have checked before posting lol. this might be a site problem rather than a program problem

This is terrible! Can you try if there is a definite size where it happens with other files? Is it always that slow? The server theoretically sits on a gbit line.

i got this error on retro
jam 3

I was just able to download Nehahra from Illinois, so maybe there is an issue with the international connection?

Might be a long shot, but try downloading it through a proxy


I’ve had issues with QI stalling or failing to download certain files myself. I get around this by downloading the zip directly from this website, putting the .zip in my “quake temporary map” folder and then installing from the QI (This way the QI doesn’t have to download it)

I haven’t noticed a trend as to which files stall out and which files don’t, though this issue mostly just started happening when I started playing quake again about a month ago. Prior to that (back in February) QI had no stalling or failed DL issues.

Quaddicted is on a new server since yesterday, the server configuration is the same though. Please check if things work ok now.

I’m getting unexpected end of ZLIB errors with quake injector when installing Quoth.

I manually downloaded the Quoth2.2full file and was able to manually extract that fine. Quake Injector doesn’t realize I’ve installed it, but its not a big deal as maps that require qouth seam to be working. I extracted it to a new directory within the quake directory, ‘Quoth’; does the versioning matter (IE do I need to get the earlier release and have two Qouth directories) ?

I had it happen once on “quoth” but every re-try worked fine. If it happens for you, please see my posts above for necessary information.

I’ve had the same problem since beginning of this year, it was working flawlessly six months ago. I never upgraded to the latest alpha, the oldest one served me well all these years since release (hundreds of files played).

I can confirm it happens with any file, not just with the ones already mentioned. It doesn’t matter if it is a small or a bigger one, download gets interrupted at random completion percentage, even after several retries. Got lucky only a couple of times, but with files under 5 mb (and I’m unable to reproduce the results). Firewall/AV seem to be working OK.

This is what I tried:

. Running from two laptops, an oldie (but trusty) XP setup and a newer one with Windows 8.1

. Both QI alphas. Reinstalling multiple times on several folders/partitions.

. Manually downloading 20 or so files, via download manager and plain old “save as”.

. Repairing internet connection/renewing IP.

. Resetting/changing modems (not being tech savvy, I ran out of ideas).

Haven’t tried yet with a new network card, or from a friend’s home. Google hasn’t shed any lights on the problem, only some obscure programming issues I didn’t even understand.

After your recent site issues and server migration, I had hoped this would be fixed. But no dice, all these lovely Map Jam releases out of my reach. At least, I’d like to know if it is something on my side.

It’s a shame, such a wonderful front-end/launcher. Not even Doom, with a much bigger community, has something like Quake Injector.

Successful or not?

As I said, there is information needed if we want to debug this. I doubt it is your end.

Not successful, none of those things I listed were.

I’m from Argentina, and my ISP is Telecom Argentina. If you need more details, let me know.

im having the same problems - with ne_ruins.zip. A straight download doesnt let me extract from the file - says its corrupted (winrar, win7 64)… other maps seem ok (nehara also gives Zlib error in injector)…

any ideas?

Sorry guys - win7 64 / Chile / im deleting the zips in the injector folder and retrying - So far this is working (right now on travail) -