Quake Injector "Failed to fetch current database"

I saw someone on the Quake reddit mention this. I tried it myself on macOS and had the same problem.

However using Chrome I can fetch https://www.quaddicted.com/reviews/quaddicted_database.xml without problem. I can also manage to fetch it using curl even when setting Quake Injector style useragent.

I’m not 100% sure if this is some new issue or just a coincidence since I don’t think I’ve tried using Quake Injector on macOS before, so my problem may be different from reddit guy’s problem. But just as a sanity check… is Quake Injector still working for other folks here or not?

It breaks easily if some database entry uses an ever-so-slightly incorrect syntax or non-standard character. A whole bunch of maps have been added in the last couple of days, so one of them might be causing the problem. At a glance, it seems everything is in order, but I can’t really check in-depth. Would be nice if people reported back how it is on their end.

I think it’s because the author list for the DM4 jam has an ampersand in it.

I tried running the injector on the manually downloaded DB and it has a database parsing error that complains about ampersand. Replacing that ampersand with “and” (i.e. “DraQu and Promeus”) makes it happy. Using the “&” entity would probably also work… I see that in some other entries.

Ah, yes. That should be it. I changed it to “&”. Thanks for the heads-up!

You betcha.