Quake on Windows 8??

Hey I am thinking about upgrading to Win8. Does anyone have done this? Does Quake run? Which port should I use? I use Fitzquake on Windows Vista

Is WIndows 8 really that different? DirectQ should probably run without any problems, I highly recommend that one.

Anything different from Vista should be fun. I think even if zou just updated to Win7 (well tested and decent) it would be worthwhile.

I don’t see why Fitzquake wouldn’t work, either. There’ll be enough backwards compatibility so no Quake player should have to worry.

I have windows 8. I haven’t found a source port that doesn’t work (I have fitzquake, directq, rmquake, quakepro and even winquake).

Spirit, could you maybe push for awareness about the Windows multi-core clock issue?

You and others keep recommending engines for Windows that have a 100% chance of not working right on any recent computer.

Like if you load up an engine without the clock-fix on Windows — examples are FitzQuake and TyrQuake — if you start walking through a map it will speed up and then maybe slow down and then you walk normal speed again – and then suddenly all the monsters are fast again.

I pushed really hard for the clock fix in FitzQuake 0.85 back at the time (a couple of weeks before 0.85 was released), but metlslime hadn’t heard of the issue in early 2009 and didn’t have the problem himself so he wasn’t sure of what it fixed. And having that problem was a bit uncommon back at the time.

Since this looks like a speed issue, a newbie is going to think this is an fps issue.

I just feel like a horrible disservice is being done with people recommending one broken engine after another. It feels like someone recommending GLQuake.

Engines that don’t have the clock fix: (sadly) FitzQuake 0.85, TyrQuake, Bengt Jardrup’s engines.

Quakespasm does not have the problem (because it uses SDL clock code). DirectQ, DarkPlaces, FTEQW, Qrack, JoeQuake, ProQuake and Mark V don’t have issue either.

Add: I guess I mentioned the above because I always thought this had a long and sustained impact on engine development in regard to quality and consistency:


Because the clock speed issue does not affect all multi-core systems. On my quad core machine, for instance, Fitz085 works just fine. As far as I can tell, it seems more an exception than the rule - judged by number of complaints I’ve seen about this very problem. At the very least it’s not a “100% chance”.

I only ever recommend Quakespasm and DirectQ as in http://www.quaddicted.com/quake/recommended_engines

I also had no problems with Tyrquake on my multicore netbook IIRC.

Is there a way to reliably test this? Or is it simple to find in the code (if available)? Would be nice to find out what systems it happens on.

It actually is a 100% probability. Maybe by chance you don’t experience the symptoms, but it is a 100% you have the problem. Maybe by luck it doesn’t happen, but you already have the disease and it is just waiting for the circumstance.

But that isn’t the bad part. People who experience the problem don’t know how to describe it and many people think it might be a setting or fps issue.

Either way, the FitzQuake 0.85 thread has a lot of inteferences and explicit references to the problem. And there are a super crapton of these kinds of threads at QuakeOne.com.

@Spirit re a way to test for the problem … I’m not sure there is an easy way to test for the problem, but I’ll make a demo of the problem sometime within this next week. Once you see it, it doesn’t take much imagination to figure out how much the problem sucks and how easily some 3rd party will falsely ascribe the problem to a setting.

Basically … the end result is very mean and cruel. Someone has a problem that is likely to be misunderstood and people will recommend different settings that won’t fix the issue, only really frustrate the person having the problem because they will try them all and none of them are going to work because it isn’t a settings problem at all.

I played WinQuake, GLQuake, DirectQ and DarkPlaces on Windows 8 Developer Preview 32-bit, there weren’t any issues. Not sure about the final version.

I know this is an old thread, but here goes …

I have been running Quake on Win 7 for 3 years just fine with no special engines. It was a bit dark, but acceptable if you push the Quake brightness option to the max.

Bought a new FAST machine (ASUS G750JH-DB71) with a great video card (nVidia GTX 780M) running Win 8.1 64-bit, and it’s simply unplayable - all kinds of lag in single player mode :frowning:

So I guess I’ll try one of these engines - maybe DarkPlaces or some such …

BTW, I’m talking about Quake 3, both “regular” and team arena

It “works”, but the action freezes for maybe a half second every 3 or 4 seconds - like I said, laggy …

That’s a good plan, also look into the vsync settings (game and vga control panel) to help you get rid of the lag