Quakespasm crash error when running map in DM mode

I’m making a SP player map for Quake with deathmatch functionality. When I try to run it in DM mode,I get a CTD in Quakespasm with the error message SV_ModelIndex: model progs/v_shot.mdl not precached. What the hell is going on? How do I fix this!

I’ve run the map in darkplaces and it doesn’t crash, but precaching errors keep coming up, especially those relating to sounds. How do I fix this issue?


How exactly do you run it?

Any mods?

There are no mods running. I run it in a standard DM mode in Quakespasm and Darkplaces. Darkplaces runs the map but spits out precaching errors whenever sounds are played or models picked up or loaded.

@‘Fat_Angus’, what operating system do you use?

It could be a variable in some specific cases, although perhaps not to the point of a crash-to-desktop, I imagine.

Windows 10. Latest version.

Although it must be noted this issue does not occur with the base game maps, both the DM only and SP maps, and even making a small test DM failed to reproduce this problem. I did notice that health and ammo models were absent in my editor of choice (Netradiant-custom) and wondered if this was part of the problem, although running the map in Darkplaces reported sounds as well as models not being precached.

What exact error messages does the engine give you, speaking of ‘Quakespasm’ - without here mentioning the entity names?

SV_ModelIndex: model progs/v_shot.mdl not precached is what I’m getting with Quakespasm.

Two suggestions:

  1. Try a separate “clean” install of Quake (just pak0.pak and pak1.pak in ID1 folder) and QuakeSpasm and run this map there

  2. Upload compiled map somewhere so others can try it out, even if the map is still WIP

v_shot.mdl is the shotgun model you see on screen - it’s always precached. So the error message is quite strange.
Perhaps open the map file in a text editor and search for v_shot.mdl to see if it’s possibly related to Netradiant’s model viewer that could have slipped in a “model” field somewhere by accident.
Hard to tell like this; maybe post the map so people can examine it themselves.

Here’s the compiled bsp file for your reference. It’ll get different results in different ports, i.e. DarkPlaces will run it, but with error messages: https://drive.google.com/file/d/1s3geSFbAthoJU5CBvqgft1dqLw1ZiOd1/view?usp=sharing

@‘Fat_Angus’, no problem on my side apparently; using ‘QSS’ engine, edition from 8th July 2021; operating system is Ubuntu 20.04.2 LTS with Wayland protocol - https://drive.google.com/file/d/125bQ2gVnx2hUbUU-CayQoSYaClPbAYqG/view?usp=sharing is a documentation video showing engine output details; the link will be dead sometime not too distant.

Yes, I got the same error - “v_shot.mdl not precached” message and crash (tested on vkQuake, which is a QS fork).

I’m not a mapper but I’ve extracted entities out of that BSP file and I noticed that worldspawn has spawnflags=2048. I’m not sure about that so I checked https://quakewiki.org/wiki/worldspawn on it: “The worldspawn entity has no spawnflags”.

So I removed that line from .ENT file and enabled vkQuake to use external entities. This way, map loads in deathmatch no problem. Try removing spawnflags in worldspawn entity:

{ "classname" "worldspawn" "message" "The Forgotten Base" "sounds" "0" "wad" "quake1.wad" "worldtype" "2" }

I would also advise to set sounds value from 4 to 11 so the map would have some music. Generally do not use “2” because it’s Title/Quake Theme and don’t use “3” because that’s the intermission screen or level completed theme. Tracks 4 to 11 are used as ambient level music in Quake.

@‘Gila’, impressive competence.

Silly me, forgot the purpose was deathmatch, even if I knew what to search for or how to run a “deathmatch” mode in the first place.

But it seems like the situation is getting clearer.


Okay, tried my best and these are the errors the engine has output, when manually loading the map in multiplayer; for that sake, had to change the map location to “maps” folder within the “id1” directory:

[code]Warning: PF_setmodel(“progs/eyes.mdl”): Model was not precached


Shutting down SDL sound

QUAKE ERROR: SV_ModelIndex: model progs/v_shot.mdl not precached[/code]

I can confirm that it works! It was that Spawnflag setting that did it. Thanks guys!