Rubicon Rumble

So far, I’ve never successfully run a mod in any engine but DirectQ. Not sure why–it’s always one thing or another.

My current problem is that the Rubicon Rumble Pack requires Quakespasm. DirectQ loads the start map, but has issues with models in the other maps or something. I’ve installed the latest version of Quakespasm and tried running the mod. The start map loads fine, but again there are crash issues upon entering another level – this time the error message is “Mod_LoadBrushModel: maps/locust.bsp has wrong version number (844124994 should be 29)”.

My only vague theory so far is that I’m not successfully running the recommended -heapsize and -zone commands, which is a common issue for me because I’m running Windows 7 and the Steam version of Quake. I did some research and took the advice found here (https://www.quaddicted.com/files/misc/Quake_customcommandlinewindows.gif) to create a shortcut and edit its target properties. This doesn’t work either: as soon as I try to add in any of the commands (such as -game rrp), it gives me the error “The name specified in the target box is not valid.”

Any help with either of these issues would be great.

The error you’re getting refers to the BSP2 map format, which DirectQ does not support.

What problems are you having with non-DirectQ engines with playing other mods?

Sorry if I wasn’t clear, but most of the problems mentioned above are with the latest version of Quakespasm, since that’s the recommended engine. I just mentioned DirectQ since that was what I tried first.

I’m not too concerned about running other engines in general, as DirectQ has been able to run just about everything I’ve ever wanted. I’d swear I even used it to run Something Wicked, which also claims to require bsp2 compatibility.

That really shouldn’t be happening with the latest (0.85.10) Quakespasm. Are you sure everything’s right on your end?

Sorry, I meant 0.90.0.

Ah, looks like I followed the wrong set of links and ended up with 0.85.9. That said, 0.85.10 is still the highest version I can find. Where did you get 0.90.0?

In any case, the model error seems to be gone, but now I’m getting a “Hunc_alloc: failed” error instead. This time I bet it really is the heapsize and zone commands.

Here: http://quakespasm.sourceforge.net/devel/

Hunk_alloc is about the memory heap size, yes. I can’t seem to recreate the error you get with adding command line arguments to the shortcut path, though.

At any rate, I recommend the Quake Injector. :wink:

Thanks. I went ahead and downloaded the latest dev version, though still having the heapsize problem of course. I can’t figure out why I’m having that error either, though if I had to guess, I’d say it’s because I’m running out of the Steam folder deep down in the Program Files directory, instead of from C:\Quake or whatever.

Is there any way to run the commands from within Quakespasm while playing? Or is getting the shortcut to work my only hope?

Alternatively, does Quake Injector automatically deal with memory heap size?

Sorry for the triple post, but I figured out Quake Injector and got RRP up and running with the proper commands. Thanks for all your help!

I really wonder this: How does a telefragged player look like?

Originally I thought to use the legless marine corpse thats used in the level for the player model while telefragged, but I ran out of time.

Later, on Daz’ stream it was decided that the player was just a head hopping along on its neck stump, climbing ladders with its teeth etc.

I do not object to this.