Textures disappearing on relaunching GTK

Having finally managed to get GTK to show textures, I am saddened to see that all texturing is lost upon relaunching the program. I truly have no idea what is going on here. The textures are available whilst mapping. Then, when closing and relaunching, it is as though they cannot be found. When I click the quake wad in the textures window, the textures load, but the previously used textures show up as notex. It is worth noting that the caulk texture is simply missing from the getgo (I can select it, but it doesn’t have the well-known pink texturing; rather it shows up with the no-tex texture. Can anyone help me understand what is going on?

I created an https://imgur.com/gallery/psHyJiR showing what is going on.

After running Bengt Jardrup’s compiler (the regular one didn’t work), I found that there are errors in the map with regards to worldspawn entity not specifying which wads to use. Could it be that this is the cause? I have tried to open the entities list to edit worldspawn, but I am not allowed to add any keys to it (meaning I amongst other things cannot choose which track to play, what the name of the map should be, et c.). Could anyone explain to me how I should go about editing the worldspawn entity to include the necessary information for the map to work?

Radiant loads the textures from all the .wad files in ID1, independent of the qbsp compiler which requires them to be listed in the map’s worldspawn entry (“wad” “c:\quake\base.wad”). Is the game configuration and the path correct in the Radiant settings? Which version of Radiant do you use (not all support Quake equally)? Maybe try a newer/different one like https://github.com/Garux/netradiant-custom/releases to see if the problem goes away.

The weird thing about the textures, is that they load, allowing me to texture the map, but then disappear when I reopen the program. If I then click to reload the textures, they do, but all the textures that have been used, are displayed with the notex texture, but still with the correct texturename.

I am currently working with GtkRadiant 1.6.6 (Apr 23 2018). When trying Netradiant, the textures do load on relaunching the editor, so clearly it is not an issue with neither the WAD file itself, nor the placement of it. The fact that all textures load upon doubleclicking the wad in GTK, but the map remains untextured, suggests it is an issue with the editor. In fact, it was only after moving the editor to my C drive, that I even got textures to load!

Now, I could then go with NetRadiant, but then as it happens to be, both with GTKR and NetR there is an issue with building the map. In GTK, the build menu is empty; clicking on BSP yields a list including five grey hyphens, and that’s it. In NetR, well, it simply doesn’t work. When running txqbsp (Bengt Jardrup), I get an error stating there were 2 errors:

[quote]WARNING: No wadfiles specified in worldmodel
WARNING: No valid wadfiles in worldmodel[/quote]

I am guessing that this might be the reason textures aren’t loaded at all when reloading the map, as it probably wants to use the textures specified in the wad, but cannot find information on the wad. It remembers all the texture names, but that is irrelevant when reloading the wad used, thus leading to the notext look of the map.

Edit: I found out how to edit worldspawn, but how should the wad be defined? The standard was

key:wad(quake1) value:{

This is a crosspost from quakeone.

I retried doing this today, basing the top of the file with that of DM1.MAP. My map-file now reads as such:

{ "sounds" "2" "worldtype" "0" "wad" "quake1.wad" "classname" "worldspawn" "message" "Testkart"
After doing this, I can reload the map in GTK with textures, so that’s an improvement.

The name of the wad file in my id1 folder is, as noted above, quake1.wad. Still, when I run txqbsp (BJ’s) on it, I get the following readout:

Now what? I am at the end of my knowledge, and really have no knowledge of how to pursue this. I should mention that my background is mainly from Q3 map editing, not Q1 (I used to dabble a bit in Worldcraft for Q1, and a tiny bit in Q3). Might it be that my not finding a proper caulk texture for Q1 is because it is not supposed to be there (not parsed by the engine at all?)?

Another issue I am having, is that I have no access to the bsp commands in the bsp menu in GTK. I have installed it multiple times, and it doesn’t change anything. There are multiple BSP options in NetRadiant, but I do prefer running GTK, as that is the software I am accustomed to.

“wad” needs a path unless qbsp.exe is in the same directory as the map file and the wad file. Since Radiant requires the wads to be in quake\id1\ you could use an absolute path for the wad key: “wad” “c:\games\quake\id1\quake1.wad” or wherever you keep it.

From within radiant you can edit it by selecting any world brush (anything that does not have a special function assigned to it). It should say “worldspawn” in the entitiy tab. Then just add “wad” for key and the path\filename fie for value.

By the way there´s a discord channel dedicated to mapping related question like that: https://discordapp.com/invite/j5xh8QT

That was the one wrong thing I (stupidly?) didn’t consider. For some reason, I just assumed it took id1 as its base path, but now:

By the way, I know there are Imgur trolls who are going to downvote my post; please ignore that. I just wanted to share my gratitude towards you.