What is mix.dem?

I’ve been playing through Madfox’s ‘abandon’ maps and have got really stuck r1b8. In searching for some help I could only find some ‘Walkthrough demos’ on the Quaddicted page. This sounded exactly what I needed and I expected some sort of video file, the archive contains the file mix.dem though and I’m unsure how to play this, can anyone help?

BTW, I’m using FTEQuake to play this as Quakespasm won’t play it (maybe an older version would)…

Ok, I figured out how to play this demo file using the FTE engine. Is there any way to navigate through the demo to the part I need and go over this until I figure out what I need, ie like a regular video file?
I could create a video file from the playback but hopefully there is a quicker way.

ETA: Problem fixed - not the demo thing, but I solved the level. It turned out there was an underwater secret door that I would never have found due to the crap underwater visibility in Quake. I had to use noclip, not to walk through walls which I consider actually cheating but just to look around, which is only slightly cheating in my opinion.

1 Like

For older maps you can use The Mark V engine. It has demo rewind and fast forward. The next version of Ironwail will have this and I assume it will work with demos that were recorded on newer maps.

Thank for this. I had considered MarkV before but it looked geared towards windows and I use Linux, I’ve got it running on Linux though with a little tweaking. I have been looking for a more basic engine to use alongside Quakespasm and this might fit the bill - I tend to get a bit caught up in all the newer options that other engines provide and this means I get pulled out of the gameplay.

Regarding demos, it turned out that the “complete walkthrough” promised on the abandon page only covers a single map, so I won’t be using it for that. I’m glad I’ve stepped into the world of demos though because it seems that all the demos available can be used for solving tricky maps if there’s no video available. Possibly Ironwail can used for more recent maps.

ETA: MarkV won’t play ‘abandon’, so I’ll have to try Ironwail. unfortunately it is Windows only and will need compiling for Linux.

Ironwail does work like a charm on Linux in my experience, if you have the right packages for compilation.

And FYI the recent vkQuake release includes a prebuilt appimage for Linux, also works great.

1 Like

I’m going to play around with MarkV for now, I like the oldschool feel and how the menu can display and load individual maps from a PAK.
I’m also wondering why ‘abandon’ doesn’t work. It’s not really new as it was made 2004-2007 and FTE plays it fine, there may be a minor glitch that is solvable.

Regarding Linux packages, I use a Debian based distro which includes packages for Quakespasm and sets up the system menu with shortcuts to all the original games and expansion (including Abyss of Pandemonium). the only downside there is that it installs them into the root filesystem so I can’t easily copy in any mods/maps - for this I use a separate install in my home folder.

What errors do you get when you say that abandon does not work in Quakespasm? Afaik it should and the demos on https://www.quaddicted.com/reviews/abandon.html are in game protocol 666 which Quakespasm also supports.

On Quakespasm and MarkV, entering ‘game abandon’ results in “game changed to abandon”, but starting a new game just results in the original Quake start map. Entering ‘map r1b8’ results in “couldn’t spawn server maps/r1b8”.
On MarkV, the menu item that should display the individual maps only displays the original maps, not abandon maps.
FTE Engine works fine though.

FIXED IT!.. and I feel a little foolish as I’ve come across this before. The PAK in ‘abandon’ is named in uppercase. Changing this to lowercase allows Quakespasm to load it. I believe this is a Linux problem and doesn’t happen on Windows. I’ll try to remember this in future.
Apparently QuakeFTE bypasses the case problem.

Oh, don’t feel foolish for that. Linux engines really should be case-insensitive by default in my opinion. Glad you solved it!

I don’t think it’s down to the engine I think it’s about how the OS works and a workaround has to be added to the engine in order for it to ignore case and it seems that FTEQuake has done this.

I want to put out another related question though… Now that I have demos working on MarkV, how do I move backwards and forwards through the playback? I can’t see an obvious way of doing this.