Which of the Quake CDs are actually pre-emphasized?

I have 7 CDs with Red Book soundtracks in total, namely:

Quake (1.01 original release)
MP1: Scourge of Armagon
MP2: Dissolution of Eternity
Shrak (v2)
Malice (USA)
X-Men: The Ravages of Apocalypse
Abyss of Pandemonium

I want to dump all of these properly to OGG and be done with it.

Now, it’s common knowledge that the original Quake soundtrack is pre-emphasized, the difference is quite obvious once you de-emphasize it, especially with track 2 (Quake Theme), it’s much less harsh and there’s much less noise. But what about the rest?

I’ve tried de-emphasizing all of these with http://sox.sourceforge.net/. Quake, official mission packs and X-Men seem to go through just fine, but the rest (Shrak, Malice and Abyss of Pandemonium) show dither errors in SoX’s output feed. So they aren’t actually pre-emphasized?

Is there a tool to check if a CD has pre-emphasis? I’ve tried using cdda2wav (from the http://cdrtools.sourceforge.net/private/cdrecord.html), but that utility is hopelessly outdated and I wasn’t able to run it on my laptop, it just showed driver errors.

Bonus question: What about Quake 2 and Hexen 2 soundtracks?

You can actually already find most of these (except AoP) here: http://quakeone.com/forums/quake-mod-releases/finished-works/7337-high-quality-music-packs.html
And the AoP soundtrack is downloadable here: http://www.quaddicted.com/files/music/impel_music.zip
It’s gonna save you some work.

Thanks, but I’d love to do this myself and actually learn something in the process.

Guess it’s back to googling for the pre-emphasis flag in TOC and how to check for it on Windows 10 64-bit.

Try EAC: http://www.exactaudiocopy.de/
there seems to be a column in the UI to indicate whether the pre-emphasis flag is set.

Keep in mind the preemphasis flag is just metadata and could be wrong, I don’t think there’s a 100% sure way to tell if preemphasis was, applied other than listening and guessing from the sound, or looking at a spectrum and guessing…

As a general rule I think you want to use the -G or --guard flag of SOX, from the manpage “Automatically invoke the gain effect to guard against clipping.”.
The sox deemph filter is applying an EQ curve, so with any processing like that you need to guard against clipping.